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Advanced Microsoft PowerPoint 2003 
Microsoft PowerPoint 2003 is a presentation graphics program that produces dynamic and 
powerful slide shows containing text, graphics, charts, video clips, and much more. 

This handout is a continuation from the Intermediate PowerPoint 2003 handout and is designed 
as a reference to some of the advanced features that PowerPoint 2003 offers. 

Using Slide Show View 
There are three main views in PowerPoint: Normal view, Slide Sorter view and Slide Show 
view. Slide Show view takes up the full computer screen like an actual slide show presentation. 
In this view, the presentation displays as the audience will see it (including graphics, timings, 
movies, animated elements, and transition effects). 

ADDING SPEAKER NOTES 
Speaker notes are useful reminders of points the user wants to make during a slide presentation. 
Speaker notes can also serve as a way to document action items that come up during the course 
of a presentation. For example, as the user goes through a bulleted list during a presentation, 
discussion with audience may produce additional bulleted items to add to the presentation at a 
later time. To save time, the user can add speaker notes instead of going to Notes Page view. 
When adding speaker notes during a presentation, the notes are added in the Speaker Notes 
dialog box. 

To add speaker notes: 
1. Select the Slide Show menu ► View Show command. 

Or 
1. Click the Slide Show button  on the 

left side of the horizontal scroll bar 
under the Normal View Pane. 

2. Right-click the slide to which a speaker 
note should be added. The slide show 
shortcut menu will appear. 

3. Select Screen ► Speaker Notes. The 
Speaker Notes dialog box will open 
(see Figure 1). 

4. Type desired speaker notes ► Close 
button. 

 
Figure 1 – Speaker Notes Dialog Box 

PRINTING SPEAKER NOTES 
It may be more efficient to print speaker notes for reference. Printed notes pages display a copy 
of the slide at the top of the page and a notes box containing the speaker notes below it. 

To print speaker notes: 
1. Open the presentation that has the notes pages to be printed. 
2. Select File ► Print…. The Print dialog box will open. 
3. Click the arrow in the Print what: drop-down box and select “Notes Pages” ► OK 

button. 
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!NOTE: 
To preview the slides that will be printed, click the Preview button in the lower-left corner of 
the Print dialog box. 

USING A PEN TO ANNOTATE THE SLIDE SHOW 
Writing on a slide with a mouse pointer during a slide show is called ink annotations or ink 
markups. For example, using the Pointer Options such as the Ballpoint Pen and Felt Tip Pen, or 
the Highlighter helps to emphasize the message by drawing an arrow to a particular text line or 
slide element. 

To use a pen to annotate the slide show: 
1. Run the slide show. 
2. Right-click in the slide which needs to be annotated. The slide 

show shortcut menu will appear. 
3. Select the Pointer Options command. A sub-menu will appear 

(see Figure 2). 
4. Select the Highlighter or Ballpoint Pen, or Felt Tip Pen. The 

mouse pointer will change into the selected pointer. 

!NOTE: 
It is also possible to use the key combination to activate the pen. The 
Felt Tip Pen will show as a result of pressing the [Ctrl+P] key 
combination during the slide show. 

 
Figure 2 - The Pointer 

Options Menu 

5. Drag to create the desired annotation. A line will appear on the current slide. 
6. To change the mouse pointer back, press the [Esc] key. 

!NOTE: 
To immediately erase the annotation on the current slide press the [Shift+E] key 
combination. 

CHANGING THE PEN COLOR 
The default pen color can be changed into any other color. Changing the pen color may enhance 
the audience attention toward the presentation. 

To change the pen color: 
1. Run the slide show. 
2. Right-click the slide to be annotated. The slide show shortcut menu will appear. 
3. Select Pointer Options ► Ink Color. 
4. Select the desired pen color. 

Presenting to a Wider Audience 
Often when presentations are to a large audience in one room, it is necessary to move the 
presentation to another computer. To do so, the user can package the presentation and any linked 
files and then unpack it on the computer where the presentation should be run. PowerPoint 
includes the PowerPoint Viewer in the package by default that allows running a presentation 
even on the computers that do not have PowerPoint installed. 
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EMBEDDING FONTS IN A PRESENTATION 
When running a presentation on a different computer, it may not look the same as on the 
computer where it was created. One reason for this may be that the fonts used are not available 
on another computer. It is a good idea to embed the fonts in the presentation to ensure that the 
fonts displayed are the fonts that have been selected. Only Windows TrueType fonts can be 
embedded. Because embedding fonts saves the fonts directly into the presentation, the size of the 
presentation file increases accordingly. 

To embed fonts in a presentation: 
1. Select the File menu ► Save As… command. The Save As dialog box opens. 
2. Type the desired file name in the File name: text box. 
3. Click the Tools button on the top right corner. A drop-down menu will open (see Figure 

3). 

 
Figure 3 - Save As Dialog Box 

4. Select the Save Options… command. The Save Options dialog box will open (see Figure 
4). 

 
Figure 4 – Save Options Dialog Box 

5. Click the Embed TrueType fonts check box ► OK button ► Save button. 
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USING THE PACKAGE FOR CD 
Users can package a presentation for burning to a CD-ROM. PowerPoint 2003 allows the users 
to copy one or more presentations along with supporting files onto a CD. The PowerPoint 
Viewer is included by default on the CD and will run the packaged presentations on other 
computers even if PowerPoint is not installed. 

To use the Package for CD: 
1. Open the PowerPoint file to be packaged. If working with a new presentation, it is 

recommended to save the presentation first. 
2. Insert a CD into the CD drive. 

!NOTE: 
For the computers with no CD recorder, 
PowerPoint allows packaging a presentation to 
a folder that can be moved any time. 

3. Select the File menu► Package for CD…. 
The Package for CD dialog box opens with 
the default CD name (see Figure 5). 

 
Figure 5 – Package for CD Dialog Box 

4. In the Name the CD: text box, enter a name for the CD. 
5. If there is more than one presentation to include into a package, click the Add Files… 

button ► select the desired file ► Add button. 

!NOTE: 
By default, presentations are set up to run automatically in the order added. To change the 
play order, select a presentation, and then click Up Arrow button or Down Arrow button 

 to move it to a new position in the list. To remove a presentation from the list, click the 
Remove button. 

6. Click the Options… button to change the 
default options for packaging. The 
Options dialog box will open (see Figure 
6). 

7. Select the necessary options ►OK 
button. 

8. Click the Copy to CD button to burn the 
CD immediately. To package the files 
into a folder, click the Copy to Folder… 
button. 

 
Figure 6 – Options Dialog Box 

!NOTE: 
When packaging the presentation, linked files are included automatically, although there is 
an exclusion option. Adding other files to the presentation package is also available. 

USING THE POWERPOINT VIEWER 
The PowerPoint Viewer is a program provided with Office 2003 that allows the user to run slide 
shows on computers that do not have PowerPoint installed.   
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To use the PowerPoint Viewer: 
1. Open the folder containing the package presentation. 
2. Open the “pptview” file. 
3. Select the Accept option to accept the terms of the License Agreement. 
4. Select the desired presentation ► Open button. 

!NOTE: 
The PowerPoint Viewer closes automatically when the slide show ends. 

PREVIEWING A PRESENTATION AS A WEB PAGE 
Before publishing the presentation to the Internet or to an intranet where users can view it in a 
browser must be saved in an HTML format. If the presentation is set up to use timings, the slide 
show will play in Web Page Preview.  If not, only the current slide will appear. 

To preview a presentation as a web page: 
1. Select the File menu ► Web Page Preview command. The first slide in the presentation 

appears in the default browser (see Figure 7). 

 
Figure 7 – Web Page Preview 

FORMATTING A PRESENTATION FOR THE WEB 
When publishing the presentation as a Web page, the user can specify the parts or elements of 
the presentation (such as speaker notes or animations) to be displayed in the Web version of the 
presentation.  The Web Options dialog box can be used to control the content and format of the 
presentation. The slide navigation controls and page colors can be added. 

Once the presentation is saved as a web page, the user can still open it in PowerPoint without 
losing content or formatting. Editing graphics and objects in a PowerPoint presentation can be 
done after the file has been saved in web format. 

To format a presentation for the Web: 
1. Select the File menu ► Save as Web Page… command. The Save As dialog box opens. 
2. Type the desired name of the web page in the File name: text box. 
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3. Click the Save in: drop-down arrow and select the location 
to save the web document. 

To change the web page title: 
1. Click the Change Title… button on the Save As dialog 

box. The Set Page Title dialog box will open (see Figure 8). 
2. Type the new title in the Page title: text box ► OK button. Figure 8 – Set Page Title 

Dialog Box 

To change format and web page options: 
1. Click the Publish… button on the Save As dialog box. The Publish as Web Page dialog 

box will open (see Figure 9). 

 
Figure 9 – Publish as Web Page Dialog Box 

2. To publish the entire presentation, select the 
Complete presentation option button in the 
Publish what? section. To publish only specific 
slides, select the Slide number option button, and 
click the spin boxes to choose the range of slides 
for publishing. 

3. In the Browser support section, select the 
browser(s) that will be used. 

4. To see how the published Web presentation looks 
in the browser after publishing, click the Open 
published Web page in browser check box. 

 
Figure 10 – Web Options Dialog Box 

5. To change web page options, click the Web Options… button. The Web Options dialog 
box will open (see Figure 10). 

6. Select the desired tab and modify as needed ► OK button ► Publish button. 

Using Organization Charts/Diagrams 
An organization chart displays the hierarchical relationships within a framework or organization. 
An organization chart consists of shapes and connecting lines. Each shape contains the name and 
represents the position of a unit. The lines or connectors between shapes represent relationships 
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between each unit in the chart. Generally, the shapes closer to the top of the chart represent a 
higher position in the hierarchy of the organization. 

CREATING AN ORGANIZATION CHART 
Organization chart slide layout can be applied to a new or an existing slide or insert an 
organization chart as a picture.  When inserting an organization chart, it appears in a drawing 
canvas. The drawing canvas can be resized and moved as desired. 

PowerPoint treats an organization chart as an object. Animation effects can be added.  The tools 
on both the Drawing and Organization Chart tool bars can be used to format or recolor the 
object. The user can change the formatting of the entire chart by selecting a preset format from 
the Organization Chart Style Gallery dialog box. 

To create an organization chart: 
1. Select the View menu ► Toolbars ► Drawing to display 

the Drawing toolbar. 
2. Click the Insert Diagram or Organization Chart button 

 on the Drawing toolbar. The Diagram Gallery dialog 
box opens (see Figure 11). 

!NOTE: 
It is also possible to select the Insert menu ► Diagram… to 
insert an organization chart or a diagram. 

3. Select the type of chart by clicking the appropriate button 
► OK button. The organization chart or diagram and the 
Organization Chart toolbar (see Figure 12) or Diagram 
toolbar (see Figure 13) will appear on the slide. 

Figure 11 – Diagram Gallery 

 
Figure 12 – Organization Chart Toolbar Figure 13 – Diagram Toolbar 

ADDING TEXT TO SHAPES 
The default organization chart contains four shapes. By default, the top shape represents the 
highest position. The three shapes below it are subordinates. The user can add and format text 
and edit, add or delete shapes. The shapes in an organization chart will adjust automatically to 
accommodate the text. When a shape is deselected after entering text, the drawing canvas 
automatically adjusts to fit the shapes within it. 

To add text to shapes: 
1. Select the shape by clicking it. The insertion point 

appears in the shape with slashes displayed around the 
shape as shown in Figure 14. The Organization Chart 
toolbar will appear. 

2. Type the text. Press the [Enter] key to move to the next 
line within the shape. 

 
Figure 14 – Adding Text to a Shape 

3. To enter text into another shape repeat steps 1-2. 
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ADDING POSITIONS TO SHAPES 
The user can add more shapes to an organization chart as needed. For example, to add a 
“Department Head” under a “Vice President,” simply add a subordinate shape to the “Vice 
President” shape. 

In addition, manually drawing additional connecting lines is accomplished by selecting the 
Connectors option from the AutoShapes menu  on the Drawing tool bar. The 
connecting line will move or adjust as needed. 

The following table describes the types of shapes that can add to the organization chart: 

Table 1 – Diagram shapes descriptions 
Type Position 
Subordinate Appears below and is connected to the selected shape. 
Coworker Appears adjacent to and is connected to the selected shape. 
Assistant Branches off from a connecting line, below the selected shape. 

To add positions to shapes: 
1. Select the shape to which the position has 

will be added. The Organization Chart 
toolbar appears. 

2. Click the Insert Shape button. A menu of 
available shapes appears (see Figure 15). 

3. Select the desired position level. The 
appearance will depend on the type of 
shape selected (see Table 1). 

 
Figure 15 – Inserting additional Shapes 

SELECTING MULTIPLE SHAPES 
The user can select multiple shapes to format or move at the same time. See Table 2 for multiple 
shape selection procedures. 

Table 2 – Multiple Shapes Selection 
To Select Method 
Multiple shapes Hold down the [Shift] or [Ctrl] key as clicking to select 

each shape. 
Multiple 
adjacent shapes 

Drag a marquee that completely includes each shape to 
select. 

All shapes on 
the same level 

Select any shape on the desired level, click the Select 
button on the Organization Chart toolbar and select the 
Level command. 

All shapes in a 
branch 

Select the desired shape, click the Select button on the 
Organization Chart toolbar and select the Branch command. 

All shapes in 
the organization 
chart 

Click the manager shape, click the Select button on the 
Organization Chart tool bar and select the Branch command. 

!NOTE: 
To move selected shapes individually, deselect the AutoLayout command in the Layout drop-
down menu of the Organization Chart toolbar. 
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REARRANGING SHAPES 
Shapes in an organization chart can change and rearrange. To change the layout, enable the 
AutoLayout command  on the Organization Chart toolbar. When AutoLayout is enabled, 
the user can drag any shape (except for the manager shapes) to new positions. Once AutoLayout 
is disabled, the user can resize a specific shape by dragging from its corners. Note that 
AutoLayout is automatically enabled when creating a new organization chart. 

There are four available formats for chart rearrangement:  Standard, Both Hanging, Left 
Hanging, or Right Hanging. Other layout options include fitting the organization chart to its 
contents, enlarging the canvas to add more white space around the chart, and scaling the chart to 
resize it. 

To rearrange the shapes: 
1. Select the shape of the highest level in 

the branch to be to rearranged. 
2. Click the Layout button on the 

Organization Chart toolbar. 
3. Select the desired layout option (see 

Figure 16).  
Figure 16 – Layout Options List 

!NOTE: 
It is also possible to click and drag each shape individually to a new position without 
selecting the highest level shape. To do so, drag the shape over another shape that has to be 
located underneath. A connecting line will be created automatically. 

FORMATTING ORGANIZATION CHARTS 
The user can format the shapes, connecting lines, and the background of an organization chart to 
enhance its appearance. For example, apply the same formatting to all assistant level shapes and 
their connecting lines and apply a different pattern for the manager level shapes. 

If an organization chart is formatted with the default Autoformat style, the tools on the Drawing 
toolbar can be used to manually format individual shapes or connecting lines. The user can 
change the font and fill color, border style and color, thickness, or add a shadow to a shape or 
connecting lines. When using the Autoformat command  to apply one of the preset design 
schemes to the chart, there are limits to changing the font color of the chart. 

To format an organization chart: 
1. Make sure the Drawing toolbar is shown. If not, select the View menu ► Toolbars ► 

Drawing. 
2. Select the shape(s) and/or line(s) to format. 
3. Click the relevant button(s) on the Drawing toolbar (see Figure 17) to format. 
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Figure 17 - Formatting an Organization Chart Using Drawing Toolbar 

4. To format the organization chart background, click any blank area of the chart to select 
the drawing canvas. 

5. Click the Fill Color button to format the background. 
6. To apply a preset design scheme to the chart, click the Autoformat button. The 

Organization Chart Style Gallery dialog box will open. 
7. Select the desired chart scheme. A preview of the selected style appears on the right ► 

Apply button. 

INSERTING A DIAGRAM 
Some types of information can be more effectively illustrated in a diagram than in a table or 
bulleted text. PowerPoint provides five predefined diagrams: “Venn,” “Cycle,” “Pyramid,” 
“Target,” and “Radial.” These diagrams are provided in the same dialog box as the organization 
chart.  Consult the following table for a description of each type of diagram. 

Table 3 – Types of Diagram 
Types of 
Diagram Descriptions 

Venn Shows areas of overlap between and among elements. 
Cycle Shows a process that has continuous cycle. 
Pyramid Shows foundation-based relationships. 
Target Shows steps towards a goal. 
Radial Shows relationships of multiple elements toward a core element. 

To insert a diagram: 
1. Select the View menu ► Toolbars ► Drawing. 
2. Click the Insert Diagram or Organizational Chart button  on the Drawing toolbar. 

The Diagram Gallery dialog box opens (see Figure 11). 
3. Click the desired diagram type ► OK button. 

WORKING WITH DIAGRAMS 
Additional shapes can be inserted and moved from front to back, labels can be added, and shapes 
within the diagram can be changed to different colors and/or styles to emphasize distinct 
concepts. 

Use the features provided on the Diagram 
toolbar to make these types of changes (see 
Figure 18). Autoformat allows the user to 
apply a predefined scheme to the entire 
diagram. AutoLayout helps maintain the 
default look of the diagram. Change to is used 
to change from one type of diagram to another 
without having to create anything new. When  Figure 18 – Diagram Toolbar 
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changing diagram types, PowerPoint enables both the AutoLayout and Autoformat features. 

Other diagram layout options include tightly fitting the drawing canvas to the diagram, 
expanding the drawing canvas to add more white space around the diagram, and scaling the 
diagram to resize it. The user must disable the AutoLayout feature to freely move diagram 
elements. 

!NOTE: 
If the diagram was first formatted manually, enabling the AutoLayout feature will resume any 
previously moved shapes to their original position. 

To work with diagrams using the Diagram toolbar: 
1. Select the diagram. 
2. To add a label, click the applicable text box ► type the text. 
3. To add a new diagram shape, click the shape to add ► Insert Shape button. 
4. To move a shape forward or backward, click the shape ► Move Shape Forward or 

Move Shape Backward button. 
5. To apply predefined format, click the Autoformat button. The Diagram Style Gallery 

dialog box will open. 
6. Click the desired style. A preview of the selected style will appear on the right ► Apply 

button. 
7. To change the diagram layout, click the Layout button. A list of available layout options 

appears. 
8. Select the desired layout option. 

Exporting Outlines and Slides 
PowerPoint allows the user to export a presentation outline to Word. The user can also edit the 
outline using Word editing tools. 

EXPORTING NOTES AND HANDOUTS TO WORD 
Slides can be exported to Word to create handouts or notes pages. Although the user can print 
these handouts or notes pages in PowerPoint, Word provides more layout and formatting options. 
There are many layout options that provide printing handouts and notes pages exported to Word, 
such as displaying multiple slides on a page, with the notes placed next to each slide or 
displaying a single slide per page. In addition, the user can select a Notes layout that prints the 
slide notes, or simply inserts blank lines for taking notes. 

The slide graphics in a Word document can be linked to the original PowerPoint presentation. 
When slides are linked, any changes made to the original PowerPoint presentation file will 
automatically be reflected in the Word document. 



To export notes and handouts to Word: 
1. Select the File menu ► Send To ► Microsoft 

Office Word…. The Send To Microsoft Office 
Word dialog box opens (see Figure 19). 

2. In the Page layout in Microsoft Office Word 
section, select the desired page layout. 

3. To create a linked file, click the Paste link option 
button in the Add slides to Microsoft Office Word 
document section ► OK button. 

 
Figure 19 – Send To Microsoft Word 

Dialog Box 

EXPORTING AN OUTLINE TO WORD 
PowerPoint allows the user to export a presentation outline to Word. The user can then edit the 
outline using Word editing tools. 

To export an outline to Word: 
1. Select the File menu ► Send To ► Microsoft Office Word…. The Send To Microsoft 

Office Word dialog box opens (see Figure 19). 
2. In the Page layout in Microsoft Office Word section, select the Outline only option 

button ► OK button. 

!NOTE: 
The user can import the outline back into PowerPoint from Word; however, most design 
aspects will be lost and will need to be reapplied. 

SAVING A PRESENTATION AS AN OUTLINE 
In addition to exporting the presentation outline to Word, the user can save a presentation outline 
in rich text format “.rtf.” The user can then edit and format the outline in Word as desired. 
Hyperlinks in the presentation are saved with the outline. Graphic images, however, are not 
saved. 

To save a presentation as an outline: 
1. Select the File menu ► Save As… command. The Save As dialog box opens (see Figure 

20). 
2. Type the name for the file in the File name: text box. 
3. Click the Save as type: drop-down arrow and select the Outline/RTF(.rtf) option. 
4. Click the Save in: drop-down arrow and select the file location ► Save button. 
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Figure 20 – Save As Dialog Box 

SAVING A SLIDE AS A GRAPHIC 
Once a slide has been saved as a graphic, the user can insert it as a picture into other types of 
documents. The slide graphic can be used as an illustration in a report, or it can be inserted into a 
web page. A slide can be saved in one of several graphic file formats, including JPEG File 
Interchange Format “*.jpg,” Graphics Interchange Format “*.gif,” Windows Metafile “*.wmf,” 
or bitmap “*.bmp.” 

The user can save a single slide or the entire presentation as a picture.  If exporting the entire 
presentation as pictures, PowerPoint creates a new folder and saves each slide to a separate file 
in the folder. 

To save a slide as a graphic: 
1. Select the relevant slide(s). 
2. Select the File menu ► Save As… command. The Save As dialog box opens (see Figure 

20). 
3. Type the name of the file in the File name: text box. 
4. Click the Save as type: drop-down arrow, and select the desired file type. 
5. Click the Save in: drop-down arrow, and select the location for the file ► Save button. 

The Microsoft PowerPoint message box will open asking if it is required to export every 
slide in the presentation or only the current slide (see Figure 21). 

 
Figure 21 – Microsoft Office PowerPoint Message Window 

6. Click the appropriate button. 
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